summaryrefslogtreecommitdiffstats
path: root/tokio-test/Cargo.toml
diff options
context:
space:
mode:
authorLucio Franco <luciofranco14@gmail.com>2019-04-23 23:17:57 -0400
committerCarl Lerche <me@carllerche.com>2019-04-23 20:17:57 -0700
commite5cf0cc717396d8131e3c8825667648fd7f17013 (patch)
treed389306a51b9e5d6b14aada2981f3a4075852489 /tokio-test/Cargo.toml
parent62f34e15ce6294f6273c33548772a70d76f2ea61 (diff)
Introduce `tokio-test` crate (#1030)
Diffstat (limited to 'tokio-test/Cargo.toml')
-rw-r--r--tokio-test/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/tokio-test/Cargo.toml b/tokio-test/Cargo.toml
new file mode 100644
index 00000000..c34d9441
--- /dev/null
+++ b/tokio-test/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "tokio-test"
+
+# When releasing to crates.io:
+# - Update html_root_url.
+# - Update doc url
+# - Cargo.toml
+# - README.md
+# - Update CHANGELOG.md.
+# - Create "v0.1.x" git tag.
+version = "0.1.0"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+homepage = "https://tokio.rs"
+documentation = "https://docs.rs/tokio-test/0.1.0/tokio_test"
+description = """
+Testing utilities for Tokio- and futures-based code
+"""
+categories = ["asynchronous", "testing"]
+publish = false
+
+[dependencies]
+futures = "0.1"
+tokio-timer = "0.2"
+tokio-executor = "0.1"