summaryrefslogtreecommitdiffstats
path: root/tokio-macros/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2019-06-24 12:34:30 -0700
committerGitHub <noreply@github.com>2019-06-24 12:34:30 -0700
commit06c473e62842d257ed275497ce906710ea3f8e19 (patch)
tree4ca6d337a892aa23266a761b35dc61e988e57954 /tokio-macros/Cargo.toml
parentaa99950b9c983b842bd2107bb771c277d09d495d (diff)
Update Tokio to use `std::future`. (#1120)
A first pass at updating Tokio to use `std::future`. Implementations of `Future` from the futures crate are updated to implement `Future` from std. Implementations of `Stream` are moved to a feature flag. This commits disables a number of crates that have not yet been updated.
Diffstat (limited to 'tokio-macros/Cargo.toml')
-rw-r--r--tokio-macros/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/tokio-macros/Cargo.toml b/tokio-macros/Cargo.toml
index 66b30338..d32becbc 100644
--- a/tokio-macros/Cargo.toml
+++ b/tokio-macros/Cargo.toml
@@ -17,9 +17,6 @@ publish = false
proc-macro = true
[features]
-# This feature comes with no promise of stability. Things will
-# break with each patch release. Use at your own risk.
-async-await-preview = []
[dependencies]
proc-macro2 = "0.4.27"