summaryrefslogtreecommitdiffstats
path: root/tests-build/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2019-10-25 12:50:15 -0700
committerGitHub <noreply@github.com>2019-10-25 12:50:15 -0700
commit227533d456fe32e48ffcd3796f1e6c8f9318b230 (patch)
tree498029aaf42dd64eeb8ef0e7d7f29802b45d4e95 /tests-build/Cargo.toml
parent03a9378297c73c2e56a6d6b55db22b92427b850a (diff)
net: move into tokio crate (#1683)
A step towards collapsing Tokio sub crates into a single `tokio` crate (#1318). The `net` implementation is now provided by the main `tokio` crate. Functionality can be opted out of by using the various net related feature flags.
Diffstat (limited to 'tests-build/Cargo.toml')
-rw-r--r--tests-build/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests-build/Cargo.toml b/tests-build/Cargo.toml
new file mode 100644
index 00000000..fb837d03
--- /dev/null
+++ b/tests-build/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "tests-build"
+version = "0.1.0"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+edition = "2018"
+publish = false
+
+[features]
+executor-without-current-thread = ["tokio-executor"]
+# macros-invalid-input = ["tokio/rt-full"]
+# net-no-features = ["tokio-net"]
+# net-with-tcp = ["tokio-net/tcp"]
+# net-with-udp = ["tokio-net/udp"]
+# net-with-uds = ["tokio-net/uds"]
+# net-with-process = ["tokio-net/process"]
+# tokio-no-features = ["tokio"]
+# tokio-with-net = ["tokio/net-full"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+tokio-executor = { path = "../tokio-executor", optional = true }
+# tokio = { path = "../tokio", optional = true, default-features = false }
+
+[dev-dependencies]
+trybuild = "1.0"