summaryrefslogtreecommitdiffstats
path: root/benches/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2019-12-24 20:53:20 -0800
committerGitHub <noreply@github.com>2019-12-24 20:53:20 -0800
commit50b91c024718c13a5d3608c63b62b2627dea5fd7 (patch)
tree8465bd561e290410e16cc10bb9dd652898cda492 /benches/Cargo.toml
parent67bf9c36f347031ca05872d102a7f9abc8b465f0 (diff)
chore: move benches to separate crate (#2028)
This allows the `benches` crate to depend on `tokio` with all feature flags. This is a similar strategy used for `examples`.
Diffstat (limited to 'benches/Cargo.toml')
-rw-r--r--benches/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/benches/Cargo.toml b/benches/Cargo.toml
new file mode 100644
index 00000000..eb26903b
--- /dev/null
+++ b/benches/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "benches"
+version = "0.0.0"
+publish = false
+edition = "2018"
+
+[dependencies]
+tokio = { version = "0.2.0", path = "../tokio", features = ["full"] }
+bencher = "0.1.5"
+
+[[bench]]
+name = "spawn"
+path = "spawn.rs"
+harness = false