summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2019-07-03 10:40:59 -0700
committerCarl Lerche <me@carllerche.com>2019-07-03 10:40:59 -0700
commitcbad83f36250dee743e9ccef0cf473fce3300d28 (patch)
tree59dba78fffb122cf5e61023b385e4b6de5a6983b /Cargo.toml
parentbd9760e124d9facb40a2cb86fdb18fdff2abae1f (diff)
signal: migrate to std::futures (#1218)
Migrate to std::futures and the futures 0.3 preview and use async/await where possible **Breaking change:** the IoFuture and IoStream definitions used to refer to Box<dyn Future> and Box<dyn Stream>, but now they are defined as Pin<...> versions which are technically breaking. No other breaking or functional changes have been made
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index de01ba67..25e84bd1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,7 +11,7 @@ members = [
"tokio-io",
"tokio-macros",
"tokio-reactor",
- # "tokio-signal",
+ "tokio-signal",
"tokio-sync",
"tokio-test",
"tokio-threadpool",