summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2019-03-21 14:30:18 -0700
committerGitHub <noreply@github.com>2019-03-21 14:30:18 -0700
commitb1172f8074b381b543ff15e23e3092fc5dc6de7d (patch)
tree6b0ffa87d724f01166ed4c65f40c3fc413e76cfe /Cargo.toml
parentcdde2e7a273cbab2085b822efcf54c6bec822681 (diff)
executor: add TypedExecutor (#993)
Adds a `TypedExecutor` trait that describes how to spawn futures of a specific type. This is useful for implementing functions that are generic over an executor and wish to support both `Send` and `!Send` cases.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1c403e43..70e264be 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,3 +21,6 @@ members = [
"tokio-udp",
"tokio-uds",
]
+
+[patch.crates-io]
+tokio-executor = { path = "tokio-executor" }