summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorjesskfullwood <38404589+jesskfullwood@users.noreply.github.com>2019-06-27 18:10:29 +0100
committerCarl Lerche <me@carllerche.com>2019-06-27 10:10:29 -0700
commit6b9e7bdace71bf64e12f7ec461a351f7eb188f60 (patch)
tree060df8190bda5ea19366d673704d867b671f0097 /Cargo.toml
parented4d4a5353d07d2428072965ea23c9a6eba5d87d (diff)
codec: update to use std-future (#1214)
Strategy was to - copy the old codec code that was temporarily being stashed in `tokio-io` - modify all the type signatures to use Pin, as literal a translation as possible - fix up the tests likewise This is intended just to get things compiling and passing tests. Beyond that there is surely lots of refactoring that can be done to make things more idiomatic. The docs are unchanged. Closes #1189
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 413a3023..7d93dcaf 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,7 @@
members = [
"tokio",
# "tokio-buf",
- # "tokio-codec",
+ "tokio-codec",
"tokio-current-thread",
"tokio-executor",
# "tokio-fs",