summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2019-06-24 12:34:30 -0700
committerGitHub <noreply@github.com>2019-06-24 12:34:30 -0700
commit06c473e62842d257ed275497ce906710ea3f8e19 (patch)
tree4ca6d337a892aa23266a761b35dc61e988e57954 /Cargo.toml
parentaa99950b9c983b842bd2107bb771c277d09d495d (diff)
Update Tokio to use `std::future`. (#1120)
A first pass at updating Tokio to use `std::future`. Implementations of `Future` from the futures crate are updated to implement `Future` from std. Implementations of `Stream` are moved to a feature flag. This commits disables a number of crates that have not yet been updated.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bf2fe1e1..e522bc7d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,24 +2,24 @@
members = [
"tokio",
- "tokio-buf",
- "tokio-codec",
+ # "tokio-buf",
+ # "tokio-codec",
"tokio-current-thread",
"tokio-executor",
- "tokio-fs",
+ # "tokio-fs",
"tokio-futures",
"tokio-io",
- "tokio-macros",
+ # "tokio-macros",
"tokio-reactor",
- "tokio-signal",
+ # "tokio-signal",
"tokio-sync",
"tokio-test",
- "tokio-threadpool",
+ # "tokio-threadpool",
"tokio-timer",
"tokio-tcp",
- "tokio-tls",
- "tokio-trace",
- "tokio-trace/tokio-trace-core",
- "tokio-udp",
- "tokio-uds",
+ # "tokio-tls",
+ # "tokio-trace",
+ # "tokio-trace/tokio-trace-core",
+ # "tokio-udp",
+ # "tokio-uds",
]