summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTaiki Endo <te316e89@gmail.com>2019-11-01 13:09:32 +0900
committerCarl Lerche <me@carllerche.com>2019-10-31 21:09:32 -0700
commit02f7264008e0333d7c4df183d3bcfbda8a6d930f (patch)
tree6100ae0b9a96178970d9e9a73e3225134a5b38a8 /Cargo.toml
parent2902e39db0151c9064be535b7983748eb9a0d92f (diff)
chore: check each feature works properly (#1695)
It is hard to maintain features list manually, so use cargo-hack's `--each-feature` flag. And cargo-hack provides a workaround for an issue that dev-dependencies leaking into normal build (`--no-dev-deps` flag), so removed own ci tool. Also, compared to running tests on all features, there is not much advantage in running tests on each feature, so only the default features and all features are tested. If the behavior changes depending on the feature, we need to test it as another job in CI.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4a2a71ba..9c0250f1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,6 +9,5 @@ members = [
# Internal
"examples",
- "tests-build",
"tests-integration",
]