summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-04-20 19:09:07 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-04-20 19:09:07 +0100
commit9420758127dbcf4de83d3f4d9354e292c015f1ba (patch)
tree729437eb871932ef73efb0b6cc7abe0bb8543126 /configure.ac
parent7934e7a6b518ec96d95fc4e9303d6fdafcac54bc (diff)
getptmfd() and fdforkpty() compat.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 31098d16..14a286b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -454,7 +454,13 @@ else
AC_LIBOBJ(getopt)
fi
-# Look for forkpty in libutil. compat/forkpty-*.c is linked if not found.
+# Look for fdforkpty and forkpty in libutil.
+AC_SEARCH_LIBS(fdforkpty, util, found_fdforkpty=yes, found_fdforkpty=no)
+if test "x$found_fdforkpty" = xyes; then
+ AC_DEFINE(HAVE_FDFORKPTY)
+else
+ AC_LIBOBJ(fdforkpty)
+fi
AC_SEARCH_LIBS(forkpty, util, found_forkpty=yes, found_forkpty=no)
if test "x$found_forkpty" = xyes; then
AC_DEFINE(HAVE_FORKPTY)