summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-03-24 10:05:53 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-03-24 10:05:53 +0000
commit2e5664d2df02a902300f8f67b4eefe0309bde5b9 (patch)
tree0696b121ca98ddf1f011bd307040634f9464d096 /configure.ac
parente87d808594e48a4c80d201d07fb86fbb9548409e (diff)
Update imsg*.[ch] from OpenBSD, add some compat bits it needs and remove some
bits it doesn't.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index db0baf1a..115dd1de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,9 +102,12 @@ AC_REPLACE_FUNCS([ \
asprintf \
cfmakeraw \
closefrom \
+ explicit_bzero \
fgetln \
fparseln \
+ getdtablecount \
getprogname \
+ recallocarray \
reallocarray \
setenv \
setproctitle \
@@ -457,23 +460,6 @@ if test "x$found_forkpty" = xyes; then
fi
AM_CONDITIONAL(NEED_FORKPTY, test "x$found_forkpty" = xno)
-# Check for BSD-style integer types.
-AC_MSG_CHECKING(for BSD-style unsigned types)
-AC_COMPILE_IFELSE([AC_LANG_SOURCE(
- [
- #include <sys/types.h>
- #ifdef HAVE_STDINT_H
- #include <stdint.h>
- #else
- #include <inttypes.h>
- #endif
- int main(void)
- { u_int8_t u8; u_int16_t u16; u_int32_t u32; u_int64_t u64; }
- ])],
- [AC_DEFINE(HAVE_BSD_TYPES) AC_MSG_RESULT(yes)],
- AC_MSG_RESULT(no)
-)
-
# Look for a suitable queue.h.
AC_CHECK_DECL(
TAILQ_CONCAT,