summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-06-06 07:59:53 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-06-06 07:59:53 +0100
commit78352fdd328b611d935ba051288191b33278cc4a (patch)
treef2d8026577daf69fbd54ca10d6a853b5dd65d204 /configure.ac
parent63f8a2cb89f776456298c3e215afcceec064ff5b (diff)
Add a small dance to daemon() to reattach tmux to the user's namespace (which
allows access to the clipboard) on OS X 10.10 and above. Chis Johnsen has done much work on and documentation of this issue, the code is copied (with some tweaks) from his reattach-to-user-namespace at: https://github.com/ChrisJohnsen/tmux-MacOSX-pasteboard Tested by Enrico Ghirardi. Will see how this goes, if it breaks stuff it might go away again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dcf62ab9..ffc022a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -569,8 +569,15 @@ case "$host_os" in
;;
*darwin*)
AC_MSG_RESULT(darwin)
- AC_DEFINE(BROKEN_CMSG_FIRSTHDR)
PLATFORM=darwin
+ #
+ # OS X CMSG_FIRSTHDR is broken, so redefine it with a working
+ # one. daemon works but has some stupid side effects, so use
+ # our internal version which has a workaround.
+ #
+ AC_DEFINE(BROKEN_CMSG_FIRSTHDR)
+ AC_LIBOBJ(daemon)
+ AC_LIBOBJ(daemon-darwin)
;;
*dragonfly*)
AC_MSG_RESULT(dragonfly)