summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-10-17 10:35:35 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-10-17 10:35:35 +0100
commita34de2e378e0cff7191a426117f44e8b81543445 (patch)
tree18311a79fd739cecd9daea4a28e166f3c9279a31 /configure.ac
parentfb02df66cc1a8fef5004d7d9c13374a3d8a33335 (diff)
Save and restore LIBS when checking for b64_ntop, reported by Ralf Friedl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83c104c3..b18b3810 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,6 +285,7 @@ if test "x$found_b64_ntop" = xno; then
AC_MSG_RESULT(no)
AC_MSG_CHECKING(for b64_ntop with -lresolv)
+ OLD_LIBS="$LIBS"
LIBS="$LIBS -lresolv"
AC_TRY_LINK(
[
@@ -297,6 +298,7 @@ if test "x$found_b64_ntop" = xno; then
found_b64_ntop=no
)
if test "x$found_b64_ntop" = xno; then
+ LIBS="$OLD_LIBS"
AC_MSG_RESULT(no)
fi
fi