summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-03-09 15:39:13 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-03-09 15:39:13 +0000
commit514a723f7489123371bded176355ead48f338ae0 (patch)
tree7b6eb1603b6669aa5d4da61409ed6865b9311614 /configure.ac
parent5d3296c53b820664d50d96b2b926f2c2c1105e97 (diff)
Solaris fixes, mostly from Dagobert Michelsen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index acfc5886..79dfcb31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,6 +350,16 @@ if test "x$found_cmsg_data" = xno; then
fi
AC_SUBST(XOPEN_DEFINES)
+# Look for err and friends in err.h.
+AC_CHECK_FUNC(err, found_err_h=yes, found_err_h=no)
+AC_CHECK_FUNC(errx, , found_err_h=no)
+AC_CHECK_FUNC(warn, , found_err_h=no)
+AC_CHECK_FUNC(warnx, , found_err_h=no)
+if test "x$found_err_h" = xyes; then
+ AC_CHECK_HEADER(err.h, , found_err_h=no)
+fi
+AM_CONDITIONAL(NO_ERR_H, [test "x$found_err_h" = xno])
+
# Look for imsg in libutil. compat/imsg.c is linked by Makefile.am if missing.
AC_SEARCH_LIBS(imsg_init, util, found_imsg_init=yes, found_imsg_init=no)
if test "x$found_imsg_init" = xyes; then