summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-06-09 15:56:50 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-06-09 15:56:50 +0100
commiteea93638c6885e45c8e103acf882f1c58b550a95 (patch)
tree3700194d5eab5160c713adac7666a62658748584 /configure.ac
parent143ccd27b4857a34ae0294eac6d05f45d27e50ef (diff)
Set AM_CFLAGS for ncurses libraries, reported by Peter Schow.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 77f20d85..83c104c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,7 +176,8 @@ if test "x$found_ncurses" = xno; then
)
fi
if test "x$found_ncurses" = xyes; then
- CPPFLAGS="$LIBNCURSES_CFLAGS $LIBTINFO_CFLAGS $CPPFLAGS"
+ AM_CFLAGS="$LIBNCURSES_CFLAGS $LIBTINFO_CFLAGS $AM_CFLAGS"
+ CFLAGS="$LIBNCURSES_CFLAGS $LIBTINFO_CFLAGS $CFLAGS"
LIBS="$LIBNCURSES_LIBS $LIBTINFO_LIBS $LIBS"
else
# pkg-config didn't work, try ncurses.