summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-10-18 23:15:49 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-10-18 23:19:08 +0100
commit3742f66abb7eeb9e31793a935fae3a2ecc0332fd (patch)
tree87ec4c39a4453612c3a243c36e638274f113f8f4 /configure.ac
parentec47907772b8302ca23b8a8a0b406c4e39e99f47 (diff)
Revert the AM_* change, I can't find a way to make AC_CHECK_HEADER use
LIBEVENT_CFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index f7a2008d..c172d6b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,8 +51,8 @@ AC_ARG_ENABLE(
AC_HELP_STRING(--enable-static, create a static build)
)
if test "x$enable_static" = xyes; then
+ LDFLAGS="$LDFLAGS -static"
test "x$PKG_CONFIG" != x && PKG_CONFIG="$PKG_CONFIG --static"
- AM_LDFLAGS="$AM_LDFLAGS -static"
fi
# Is this gcc?
@@ -129,7 +129,7 @@ PKG_CHECK_MODULES(
LIBEVENT,
libevent,
[
- AM_CFLAGS="$LIBEVENT_CFLAGS $AM_CFLAGS"
+ CPPFLAGS="$LIBEVENT_CFLAGS $CPPFLAGS"
LIBS="$LIBEVENT_LIBS $LIBS"
found_libevent=yes
],
@@ -156,7 +156,7 @@ PKG_CHECK_MODULES(
LIBNCURSES,
ncurses,
[
- AM_CFLAGS="$LIBNCURSES_CFLAGS $AM_CFLAGS"
+ CPPFLAGS="$LIBNCURSES_CFLAGS $CPPFLAGS"
LIBS="$LIBNCURSES_LIBS $LIBS"
found_ncurses=yes
],
@@ -646,7 +646,4 @@ AM_CONDITIONAL(IS_HPUX, test "x$PLATFORM" = xhpux)
AM_CONDITIONAL(IS_UNKNOWN, test "x$PLATFORM" = xunknown)
# autoconf should create a Makefile.
-AC_SUBST(AM_CFLAGS)
-AC_SUBST(AM_CPPFLAGS)
-AC_SUBST(AM_LDFLAGS)
AC_OUTPUT(Makefile)