summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-05-27 10:37:06 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-05-27 10:37:06 +0100
commitf2ec81cf210ec30418a7906abec004f7321b94f2 (patch)
tree7157c6693bac68532c3f231326de5e9fb6607238 /Makefile.am
parent20d97eb849282ae2ca5ff543f6826d689a07199a (diff)
Add flag for -pg.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 45288a26..d2a1cab5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,10 @@ if IS_COVERAGE
CFLAGS += -g -O0 --coverage
LDFLAGS += --coverage
endif
+if IS_PROFILE
+CFLAGS += -g -O0 -pg
+LDFLAGS += -pg
+endif
CPPFLAGS += -iquote.
endif