summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-05-27 18:04:25 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-05-27 18:04:25 +0100
commitcfef0c6658be29967f883997ba7139ca3bdef2ba (patch)
treebe0b41d18c5a8c8ecd4a230b35b8b089e52f8d03 /Makefile.am
parent20d97eb849282ae2ca5ff543f6826d689a07199a (diff)
getprogname() and setproctitle() on Linux.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 45288a26..6d6a9e7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,7 @@ if IS_GCC
CFLAGS += -std=gnu99 -O2
if IS_DEBUG
CFLAGS += -g
-CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
+CFLAGS += -Wno-long-long -Wall -W -Wformat=2
CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
@@ -194,6 +194,15 @@ endif
if NO_DAEMON
nodist_tmux_SOURCES += compat/daemon.c
endif
+if NO_DAEMON
+nodist_tmux_SOURCES += compat/daemon.c
+endif
+if NO_GETPROGNAME
+nodist_tmux_SOURCES += compat/getprogname.c
+endif
+if NO_SETPROCTITLE
+nodist_tmux_SOURCES += compat/setproctitle.c
+endif
if NO_SETENV
nodist_tmux_SOURCES += compat/setenv.c
endif