summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2020-04-29 13:56:10 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2020-04-29 13:56:10 +0100
commitb06235c345d8d6426d3c8208b4e475e6c60ac884 (patch)
tree496515ffeaeebeaba5f1e660a7e2b111ea86abdf /Makefile.am
parent7c52d702e4bb6d3783984001678f5be98b56b7e6 (diff)
Improve command prompt completion:
- Show a menu with completions if there are multiple. - Don't complete argument stuff (options, layouts) at start of text. - For -t and -s, if there is no : then complete sessions but if there is a :, show a menu of all windows in the session rather than trying to complete the window name which is a bit useless if there are duplicates. Lots of scope for being more sophisticated left here.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a395ecdb..97174c1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ LDADD = $(LIBOBJS)
if IS_GCC
AM_CFLAGS += -std=gnu99 -O2
if IS_DEBUG
-AM_CFLAGS += -g
+AM_CFLAGS += -g -O0
AM_CFLAGS += -Wno-long-long -Wall -W -Wformat=2
AM_CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
AM_CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare