summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-05-27 18:04:45 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-05-27 18:04:45 +0100
commit762fa58ce8de79ef06fdc673ee271dba1f193a44 (patch)
tree28e886eaaa59377901920daee36f0bf0416c9d96 /Makefile.am
parentf2ec81cf210ec30418a7906abec004f7321b94f2 (diff)
parentcfef0c6658be29967f883997ba7139ca3bdef2ba (diff)
Merge branch 'master' of github.com:tmux/tmux
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d2a1cab5..723fb77d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,7 @@ if IS_GCC
CFLAGS += -std=gnu99 -O2
if IS_DEBUG
CFLAGS += -g
-CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
+CFLAGS += -Wno-long-long -Wall -W -Wformat=2
CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
@@ -198,6 +198,15 @@ endif
if NO_DAEMON
nodist_tmux_SOURCES += compat/daemon.c
endif
+if NO_DAEMON
+nodist_tmux_SOURCES += compat/daemon.c
+endif
+if NO_GETPROGNAME
+nodist_tmux_SOURCES += compat/getprogname.c
+endif
+if NO_SETPROCTITLE
+nodist_tmux_SOURCES += compat/setproctitle.c
+endif
if NO_SETENV
nodist_tmux_SOURCES += compat/setenv.c
endif