summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-10-18 23:15:49 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-10-18 23:19:08 +0100
commit3742f66abb7eeb9e31793a935fae3a2ecc0332fd (patch)
tree87ec4c39a4453612c3a243c36e638274f113f8f4 /Makefile.am
parentec47907772b8302ca23b8a8a0b406c4e39e99f47 (diff)
Revert the AM_* change, I can't find a way to make AC_CHECK_HEADER use
LIBEVENT_CFLAGS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 19 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 82101c57..bce84b91 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,49 +12,49 @@ dist-hook:
grep "^#enable_debug=" configure
# Preprocessor flags.
-AM_CPPFLAGS += @XOPEN_DEFINES@ -DTMUX_CONF="\"$(sysconfdir)/tmux.conf\""
+CPPFLAGS += @XOPEN_DEFINES@ -DTMUX_CONF="\"$(sysconfdir)/tmux.conf\""
# glibc as usual does things ass-backwards and hides useful things by default,
# so everyone has to add this.
if IS_GLIBC
-AM_CFLAGS += -D_GNU_SOURCE
+CFLAGS += -D_GNU_SOURCE
endif
# Set flags for gcc.
if IS_GCC
-AM_CFLAGS += -std=gnu99 -O2
+CFLAGS += -std=gnu99 -O2
if IS_DEBUG
-AM_CFLAGS += -g
-AM_CFLAGS += -Wno-long-long -Wall -W -Wformat=2
-AM_CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
-AM_CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
-AM_CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
-AM_CFLAGS += -Wdeclaration-after-statement -Wno-pointer-sign -Wno-attributes
-AM_CPPFLAGS += -DDEBUG
+CFLAGS += -g
+CFLAGS += -Wno-long-long -Wall -W -Wformat=2
+CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
+CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
+CFLAGS += -Wdeclaration-after-statement -Wno-pointer-sign -Wno-attributes
+CPPFLAGS += -DDEBUG
endif
if IS_COVERAGE
-AM_CFLAGS += -g -O0 --coverage
-AM_LDFLAGS += --coverage
+CFLAGS += -g -O0 --coverage
+LDFLAGS += --coverage
endif
if IS_PROFILE
-AM_CFLAGS += -g -O0 -pg
-AM_LDFLAGS += -pg
+CFLAGS += -g -O0 -pg
+LDFLAGS += -pg
endif
-AM_CPPFLAGS += -iquote.
+CPPFLAGS += -iquote.
endif
# Set flags for Solaris.
if IS_SUNOS
if IS_GCC
-AM_CPPFLAGS += -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
+CPPFLAGS += -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
else
-AM_CPPFLAGS += -D_XPG4_2 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
+CPPFLAGS += -D_XPG4_2 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
endif
endif
# Set flags for Sun CC.
if IS_SUNCC
-AM_CFLAGS += -erroff=E_EMPTY_DECLARATION
+CFLAGS += -erroff=E_EMPTY_DECLARATION
endif
# Set _LINUX_SOURCE_COMPAT for AIX for malloc(0).
@@ -64,7 +64,7 @@ endif
# Set flags for NetBSD.
if IS_NETBSD
-AM_CPPFLAGS += -D_OPENBSD_SOURCE
+CPPFLAGS += -D_OPENBSD_SOURCE
endif
# List of sources.