summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2015-07-14 08:14:35 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2015-07-14 08:14:35 +0100
commitbed3069fd746741286e624126774f98ed51fbbdf (patch)
treea8516d1725b98ff3b86c23c8ea4d8927b438ca3d /Makefile.am
parent73f9f0334ce639e2f05cb0646af2c81881859a2e (diff)
Add _LINUX_SOURCE_COMPAT on AIX.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 99163c2c..3173ba99 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,11 @@ if IS_SUNCC
CFLAGS += -erroff=E_EMPTY_DECLARATION
endif
+# Set _LINUX_SOURCE_COMPAT for AIX for mallocing 0 bytes
+if IS_AIX
+DEFS += -D_LINUX_SOURCE_COMPAT=1
+endif
+
# List of sources.
dist_tmux_SOURCES = \
arguments.c \