summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-10-18 20:34:18 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-10-18 20:34:18 +0100
commitbd1dc89a5d9871e5f3b0f5333765f66261dbf1f8 (patch)
tree8d40869b17a9ee681e4767c1d2e4ce2976b04971 /Makefile.am
parent66d637be3d5a1c6b43105b16fbb7ac56311a20a1 (diff)
*.h can go in dist_tmux_SOURCES, from Dilyan Palauzov.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 130df784..d9c09d1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,7 @@ CLEANFILES = tmux.1.mdoc tmux.1.man
# Distribution tarball options.
EXTRA_DIST = \
CHANGES FAQ README TODO COPYING example_tmux.conf compat/*.[ch] \
- compat.h tmux.h osdep-*.c xmalloc.h mdoc2man.awk tmux.1
+ osdep-*.c mdoc2man.awk tmux.1
dist-hook:
make clean
grep "^#enable_debug=" configure
@@ -89,8 +89,8 @@ dist_tmux_SOURCES = \
cmd-detach-client.c \
cmd-display-message.c \
cmd-display-panes.c \
- cmd-find.c \
cmd-find-window.c \
+ cmd-find.c \
cmd-if-shell.c \
cmd-join-pane.c \
cmd-kill-pane.c \
@@ -142,8 +142,9 @@ dist_tmux_SOURCES = \
cmd-wait-for.c \
cmd.c \
colour.c \
- control.c \
+ compat.h \
control-notify.c \
+ control.c \
environ.c \
format.c \
grid-view.c \
@@ -177,6 +178,7 @@ dist_tmux_SOURCES = \
status.c \
style.c \
tmux.c \
+ tmux.h \
tty-acs.c \
tty-keys.c \
tty-term.c \
@@ -187,6 +189,7 @@ dist_tmux_SOURCES = \
window-copy.c \
window.c \
xmalloc.c \
+ xmalloc.h \
xterm-keys.c
nodist_tmux_SOURCES = osdep-@PLATFORM@.c