summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Viennot <nicolas@viennot.biz>2016-01-11 02:20:10 -0800
committerNicolas Viennot <nicolas@viennot.biz>2016-01-11 02:54:09 -0800
commit6dc58ab6deef30020953882331c88ca6c80b4f2d (patch)
treeec400ef2c9a2f934a836672b0f06e259e907eb00 /configure.ac
parenta2520da19591599538f8dc26b3bd6bf7a2619300 (diff)
Lower the required glib version to 2.8 for static builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 663a51c5..10d761bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,7 @@ if test "x$found_static" = xyes; then
CPPFLAGS="$LIBCRYPTO_CFLAGS $CPPFLAGS"
LIBS="$LIBCRYPTO_LIBS $LIBS"
])
+ # See more static settings below... (search for found_static)
fi
# Is this gcc?
@@ -451,6 +452,12 @@ AM_CONDITIONAL(NO_GETOPT, [test "x$found_getopt" = xno])
if test "x$found_static" = xyes; then
# libc and libdl should be dynamically linked.
+ # but we want to lower our requirements for libc's version.
+ # so we extract some symobls and add them here
+ if test `uname -m` = x86_64; then
+ LIBS="compat/memcpy.o -Wl,--wrap=memcpy $LIBS"
+ fi
+ LIBS="compat/clock_gettime.o libc/fdelt_chk.o $LIBS"
LIBS="-Wl,-Bstatic ${LIBS/-ldl/} -Wl,-Bdynamic -ldl"
fi