summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPaul Masurel <paul.masurel@gmail.com>2018-09-06 10:10:40 +0900
committerGitHub <noreply@github.com>2018-09-06 10:10:40 +0900
commitcec9956a01d922f6ce2e5dee3da003512597e3ed (patch)
tree3c0a29e68eb63a2d2b6f67adcdc2c0baa7835ae0 /Cargo.toml
parentc64972e03966671c5e3983fe018758d20b9b32e9 (diff)
Issue/389 (#405)
* Setting up the dependency. * Completed README
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ab767d3..098ab91 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -48,6 +48,7 @@ census = "0.1"
fnv = "1.0.6"
owned-read = "0.4"
failure = "0.1"
+fail = "0.2"
[target.'cfg(windows)'.dependencies]
winapi = "0.2"
@@ -60,12 +61,20 @@ opt-level = 3
debug = false
lto = true
debug-assertions = false
+overflow-checks = false
+
+[profile.test]
+debug-assertions = true
+overflow-checks = true
[features]
-default = ["mmap"]
+# by default no-fail is disabled. We manually enable it when running test.
+default = ["mmap", "no_fail"]
mmap = ["fst/mmap", "atomicwrites"]
lz4-compression = ["lz4"]
+no_fail = ["fail/no_fail"]
[badges]
travis-ci = { repository = "tantivy-search/tantivy" }
+