summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 12 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3b855e181..9967f9b37 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "starship"
-version = "1.18.2"
+version = "1.19.0"
authors = ["Starship Contributors"]
build = "build.rs"
categories = ["command-line-utilities"]
@@ -42,7 +42,7 @@ gix-max-perf = ["gix-features/zlib-ng", "gix/fast-sha1"]
gix-faster = ["gix-features/zlib-stock", "gix/fast-sha1"]
[dependencies]
-chrono = { version = "0.4.37", default-features = false, features = ["clock", "std", "wasmbind"] }
+chrono = { version = "0.4.38", default-features = false, features = ["clock", "std", "wasmbind"] }
clap = { version = "4.5.4", features = ["derive", "cargo", "unicode"] }
clap_complete = "4.5.2"
dirs = "5.0.1"
@@ -58,7 +58,7 @@ log = { version = "0.4.21", features = ["std"] }
notify-rust = { version = "4.11.0", optional = true }
nu-ansi-term = "0.50.0"
once_cell = "1.19.0"
-open = "5.1.2"
+open = "5.1.3"
# update os module config and tests when upgrading os_info
os_info = "3.8.2"
path-slash = "0.2.1"
@@ -69,9 +69,9 @@ rand = "0.8.5"
rayon = "1.10.0"
regex = { version = "1.10.4", default-features = false, features = ["perf", "std", "unicode-perl"] }
rust-ini = "0.21.0"
-semver = "1.0.22"
-serde = { version = "1.0.197", features = ["derive"] }
-serde_json = "1.0.115"
+semver = "1.0.23"
+serde = { version = "1.0.202", features = ["derive"] }
+serde_json = "1.0.117"
sha1 = "0.10.6"
shadow-rs = { version = "0.27.1", default-features = false }
# battery is optional (on by default) because the crate doesn't currently build for Termux
@@ -80,10 +80,10 @@ starship-battery = { version = "0.8.3", optional = true }
strsim = "0.11.1"
systemstat = "=0.2.3"
terminal_size = "0.3.0"
-toml = { version = "0.8.12", features = ["preserve_order"] }
-toml_edit = "0.22.9"
+toml = { version = "0.8.13", features = ["preserve_order"] }
+toml_edit = "0.22.13"
unicode-segmentation = "1.11.0"
-unicode-width = "0.1.11"
+unicode-width = "0.1.12"
urlencoding = "2.1.3"
versions = "6.2.0"
which = "6.0.1"
@@ -96,7 +96,7 @@ home = "0.5.9"
shell-words = "1.1.0"
[dependencies.schemars]
-version = "0.8.16"
+version = "0.8.20"
optional = true
features = ["preserve_order", "indexmap2"]
@@ -104,7 +104,7 @@ features = ["preserve_order", "indexmap2"]
deelevate = "0.2.0"
[target.'cfg(windows)'.dependencies.windows]
-version = "0.54.0"
+version = "0.56.0"
features = [
"Win32_Foundation",
"Win32_UI_Shell",
@@ -124,7 +124,7 @@ dunce = "1.0.4"
winres = "0.1.12"
[dev-dependencies]
-mockall = "0.12"
+mockall = "0.12.1"
tempfile = "3.10.1"
[profile.release]