summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Knaack <davidkna@users.noreply.github.com>2024-03-29 12:14:57 +0100
committerGitHub <noreply@github.com>2024-03-29 12:14:57 +0100
commit796a411602c9ca4e5103c54247440f4efe892918 (patch)
tree992d97220a02922bbce458953fcd4c404113efb3 /Cargo.toml
parente4d0c2db5a743a6624f97e5b3ead555e994c5f09 (diff)
fix: replace unmaintained crates `yaml-rust`, `dirs-next` (#5887)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c1d885751..011aeab06 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,7 +45,7 @@ gix-faster = ["gix-features/zlib-stock", "gix/fast-sha1"]
chrono = { version = "0.4.37", default-features = false, features = ["clock", "std", "wasmbind"] }
clap = { version = "4.5.4", features = ["derive", "cargo", "unicode"] }
clap_complete = "4.5.1"
-dirs-next = "2.0.0"
+dirs = "5.0.1"
dunce = "1.0.4"
gethostname = "0.4.3"
# default feature restriction addresses https://github.com/starship/starship/issues/4251
@@ -87,7 +87,7 @@ unicode-width = "0.1.11"
urlencoding = "2.1.3"
versions = "6.2.0"
which = "6.0.1"
-yaml-rust = "0.4.5"
+yaml-rust2 = "0.7.0"
process_control = { version = "4.1.0", features = ["crossbeam-channel"] }