summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatan Kushner <hello@matchai.dev>2021-07-02 16:54:52 -0400
committerMatan Kushner <hello@matchai.dev>2021-07-02 16:54:52 -0400
commit8bb76e08eeacdbeb7b51a2aee1c7cc9dbfba2b81 (patch)
treeda1a891376d494c6a5b0f17caf3f50560c07f228 /Cargo.toml
parenta123df24dcd4b360c71b92a661b8c405dcbcbd62 (diff)
Add binary cachingbinary-caching
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1a2ad5e66..67f911ca3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -49,7 +49,8 @@ once_cell = "1.8.0"
chrono = "0.4.19"
sys-info = "0.9.0"
byte-unit = "4.0.12"
-starship_module_config_derive = { version = "0.2.1", path = "starship_module_config_derive" }
+starship_module_config_derive = { version = "0.2.1", path = "crates/starship_module_config_derive" }
+starship-cache = { version = "0.1.0", path = "crates/starship-cache" }
yaml-rust = "0.4.5"
pest = "2.1.3"
pest_derive = "2.1.0"
@@ -103,3 +104,6 @@ lto = true
[[bin]]
name = "starship"
path = "src/main.rs"
+
+[workspace]
+members = ["crates/*"]