summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBastian Venthur <bastian.venthur@flixbus.com>2018-10-17 09:12:04 +0200
committerBrian May <brian@linuxpenguins.xyz>2018-10-17 20:54:28 +1100
commitd4bbf3b68d26cae09a005bb29094fe3b792a78d6 (patch)
tree61cde7bd8121d0921af44a9b76a6826575237122 /setup.py
parent41f5b3e9c12808f512b85c715e430fbd109f4742 (diff)
Added coverage report to tests
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 44a9e3b..d5f3c7e 100755
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,12 @@ setup(
'sshuttle = sshuttle.cmdline:main',
],
},
- tests_require=['pytest', 'pytest-runner', 'mock'],
+ tests_require=[
+ 'pytest',
+ 'pytest-cov',
+ 'pytest-runner',
+ 'mock',
+ 'flake8',
+ ],
keywords="ssh vpn",
)