summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBrian May <brian@linuxpenguins.xyz>2016-04-18 11:40:43 +1000
committerBrian May <brian@linuxpenguins.xyz>2016-04-18 11:44:05 +1000
commit89c5b570190a32da2cfaea061b87005177fea16d (patch)
tree5caf584e8736dce0cd1a6f91d351d14a12f3d907 /setup.py
parenta8b288338b9a3eff1ec784efb5cf75dfbbae6d34 (diff)
Attempt readthedocs workaround
readthedocs alters docs/conf.py which in turn means python_scm detects a version and incorrectly adjusts the version number. Here we try to work around this problem. We do this by renaming the docs/conf.py file and copying it back to docs/conf.py when setup.py is invoked. This way, hopefully, scm won't see the changes to docs/conf.py References: http://stackoverflow.com/questions/35811267/readthedocs-and-setuptools-scm-version-wrong/36386177 https://github.com/pypa/setuptools_scm/issues/84
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 58a889d..765e799 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,12 @@
# along with python-tldap If not, see <http://www.gnu.org/licenses/>.
from setuptools import setup, find_packages
+import shutil
+with open("./docs/conf.orig.py", "r") as src:
+ with open("./docs/conf.py", "w") as dst:
+ dst.write("# FILE COPIED FROM conf.orig.py; DO NOT CHANGE\n")
+ shutil.copyfileobj(src, dst)
def version_scheme(version):
from setuptools_scm.version import guess_next_dev_version