summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBrian May <brian@linuxpenguins.xyz>2020-12-16 20:11:13 +1100
committerBrian May <brian@linuxpenguins.xyz>2020-12-16 20:11:13 +1100
commit4a65f97c8bafbd08b1cf7be1764b3b5212a4d192 (patch)
tree57da41cb48d8a18f3f2faa0c31e3cda013898e85 /setup.py
parent461e676973c692f2f3fa07beebbc5bd1d9babcab (diff)
Drop testing of Python 3.5
Due to message from CI: DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 705a6b6..2ea100d 100755
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,6 @@ setup(
"License :: OSI Approved :: "
"GNU Lesser General Public License v2 or later (LGPLv2+)",
"Operating System :: OS Independent",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
@@ -61,7 +60,7 @@ setup(
'sshuttle = sshuttle.cmdline:main',
],
},
- python_requires='>=3.5',
+ python_requires='>=3.6',
install_requires=[
'psutil',
],