summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBrian May <brian@linuxpenguins.xyz>2024-02-19 11:02:04 +1100
committerBrian May <brian@linuxpenguins.xyz>2024-02-19 11:21:31 +1100
commitdd037dd8ef6f0ff648361b06926cd2aefa936a76 (patch)
tree7297b9f7f2dd2586f2902b18c9409d202333ce22 /pyproject.toml
parent89bd3fc2f3b037d413ba505dd86f2978131e3089 (diff)
Add experimental peotry and nix flake stuff
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..07a99b5
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,24 @@
+[tool.poetry]
+name = "sshuttle"
+version = "1.1.1"
+description = "Transparent proxy server that works as a poor man's VPN. Forwards over ssh. Doesn't require admin. Works with Linux and MacOS. Supports DNS tunneling."
+authors = ["Brian May <brian@linuxpenguins.xyz>"]
+license = "LGPL-2.1"
+readme = "README.rst"
+
+[tool.poetry.dependencies]
+python = "^3.10"
+
+[tool.poetry.group.dev.dependencies]
+pytest = "^8.0.1"
+pytest-cov = "^4.1.0"
+flake8 = "^7.0.0"
+pyflakes = "^3.2.0"
+bump2version = "^1.0.1"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry.scripts]
+sshuttle = "sshuttle.cmdline:main"