summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorpgen <p.gen.progs@gmail.com>2015-11-19 23:28:29 +0100
committerpgen <p.gen.progs@gmail.com>2015-11-21 10:51:51 +0100
commit0d0735b0d09178ca9098f9648198d9493241c8ae (patch)
treea57fce1710915252c8b19a7238bb8062fb1e46e3 /configure.ac
parentd2ff6494e7c9fa0365a5d0af4b2a07e75b044464 (diff)
Put the code under autoconf control
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8ed5ff8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,41 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+m4_define(my_version, [0.9])
+
+AC_PREREQ([2.69])
+AC_INIT([smenu], [my_version], [p.gen.progs@gmail.com])
+AC_CONFIG_SRCDIR([smenu.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign -Wall])
+
+# Checks for programs.
+AC_USE_SYSTEM_EXTENSIONS
+AC_PROG_AWK
+AC_PROG_CC_STDC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
+AC_CHECK_HEADER(term.h,
+ [AC_SEARCH_LIBS(tgetent, [curses ncursesw ncurses], [HAVE_CURSES=True])], ,
+ [#include <curses.h>
+ ])
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([langinfo.h locale.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h wchar.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([mblen memset nl_langinfo pathconf regcomp setlocale strchr strdup strrchr])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
+