summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorpgen <p.gen.progs@gmail.com>2018-05-21 23:45:11 +0200
committerpgen <p.gen.progs@gmail.com>2018-05-25 00:46:20 +0200
commita18d18a70133697dbf68de3b2781774311086259 (patch)
tree6f93f6fb481d1e72f006a4fe42b871a7a0475a98 /Makefile.am
parent7343bbf9650bd1a763ca3b669302efe82dd34d8e (diff)
Add the subpackage '-tests' in the specfile
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7862aa5..b8655a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,17 @@
bin_PROGRAMS = smenu
smenu_SOURCES = smenu.c
dist_man_MANS = smenu.1
-EXTRA_DIST = smenu.spec.in ChangeLog smenu.spec build.sh version COPYRIGHT LICENSE.rst README.rst examples build-aux tests
+EXTRA_DIST = smenu.spec.in smenu.spec ChangeLog build.sh version \
+ COPYRIGHT LICENSE.rst README.rst examples build-aux tests
+
+dist-hook:
+ @chmod u+rw $(distdir)/tests; \
+ cd $(distdir)/tests ; \
+ find * -name 'data*' -o \
+ -name '*.in' -o \
+ -name '*.tst' -o \
+ -name '*.good' \
+ | cpio -o > tests.cpio 2>/dev/null
+ @gzip -f9 $(distdir)/tests/tests.cpio
+ @find $(distdir)/tests/* -type d \
+ -exec rm -rf {} +