summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 16 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2dad6ce..bc0054b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "shiplift"
-version = "0.6.0"
+version = "0.7.0"
authors = ["softprops <d.tangren@gmail.com>"]
description = "A Rust interface for maneuvering Docker containers"
documentation = "https://docs.rs/shiplift"
@@ -18,31 +18,35 @@ coveralls = { repository = "softprops/shipflit" }
maintenance = { status = "actively-developed" }
[dependencies]
-base64 = "0.11"
-byteorder = "1.3"
-bytes = "0.4"
+base64 = "0.13"
+byteorder = "1.4"
+bytes = "1.0"
chrono = { version = "0.4", optional = true, features = ["serde"] }
flate2 = "1.0"
futures-util = "0.3"
-futures_codec = "0.3"
-hyper = "0.13"
-hyper-openssl = { version = "0.8", optional = true }
-hyperlocal = { version = "0.7", optional = true }
+futures_codec = "0.4"
+hyper = { version = "0.14", features = ["client", "http1", "tcp", "stream"] }
+hyper-openssl = { version = "0.9", optional = true }
+hyperlocal = { version = "0.8", optional = true }
log = "0.4"
mime = "0.3"
openssl = { version = "0.10", optional = true }
-pin-project = "0.4"
+pin-project = "1.0"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
tar = "0.4"
-tokio = "0.2"
+tokio = "1.0"
url = "2.1"
+# XXX: This is a temporary dependency for the reexport! macro in lib.rs. Remove
+# me before 0.9.0 is released.
+paste = "1.0"
+
[dev-dependencies]
-env_logger = "0.7"
+env_logger = "0.8"
# Required for examples to run
futures = "0.3.1"
-tokio = { version = "0.2.6", features = ["macros"] }
+tokio = { version = "1.0", features = ["macros", "rt-multi-thread"] }
[features]
default = ["chrono", "unix-socket", "tls"]