summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVegard Sandengen <vegardsandengen@gmail.com>2019-02-22 14:55:51 +0100
committerdoug tangren <d.tangren@gmail.com>2019-02-22 08:55:51 -0500
commitebb293813fb1c92149a5cc802043ba41f4ddf1a5 (patch)
tree290bc27a1990bca6c2b1c80109a9c6770013fbd1 /Cargo.toml
parent2a40dc00e6aeb611db8095dc8646e5132fea356b (diff)
Migrate serde dependency to use derive feature (#152)
This is in line with best practices recommended by serde[1]. This will also resolve downstream crates depending on shiplift who enable the serde derive feature, due to Cargos unification of features for each crate[2]. [1]: https://github.com/serde-rs/serde/issues/1441 [2]: https://github.com/rust-lang/cargo/issues/4361#issuecomment-348538243
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0def440..1ee57a5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,8 +34,7 @@ tokio = "0.1.15"
tokio-codec = "0.1.1"
tokio-io = "0.1.11"
url = "1.7.2"
-serde = "1.0.87"
-serde_derive = "1.0.87"
+serde = { version = "1.0.87", features = ["derive"] }
serde_json = "1.0.38"
[dev-dependencies]