summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorThomas Eizinger <thomas@eizinger.io>2019-12-27 04:17:07 +0100
committerDoug Tangren <d.tangren@gmail.com>2019-12-26 22:17:07 -0500
commita368a93e1f217cd38a0fe52456b4ab03008d75d4 (patch)
tree3ca636a28ebf6da3d7f40044e5b3ac85dbc97748 /Cargo.toml
parent1718105d19c53e817de9776011daacb17f6ac275 (diff)
Re-export hyper::Uri as shiplift::Uri (#209)
This patch removes the explicit dependency on the http crate and instead accesses the re-exported version of hyper. This should make the update process slightly easier because those versions would need to be kept in sync manually. We also re-export hyper::Uri as shiplift::Uri because it is part of the public API of shiplift::Docker. This allows users to access the Uri type without having to seperately depend on http or hyper.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a550b43..c85ed4e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,7 +26,6 @@ bytes = "0.4"
chrono = { version = "0.4", optional = true, features = ["serde"] }
flate2 = "1.0"
futures = "0.1"
-http = "0.1"
hyper = "0.12"
hyper-openssl = { version = "0.7", optional = true }
hyperlocal = { version = "0.6", optional = true }