summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authormaowtm <micromaomao@gmail.com>2021-01-16 00:10:24 +0000
committerGitHub <noreply@github.com>2021-01-15 19:10:24 -0500
commit71a2d687187b7cc9f7954cbc041e3dd34349d0aa (patch)
tree403cb03291116f7586f4dbfc198eb5978e75425f /Cargo.toml
parentce4e36a20c81b96eedff47cd76b5bdeaa8c99b28 (diff)
Upgrade all dependencies (#246)
* Upgrade dependencies and add required features * Special case for parsing unix:// url in Docker::new hyper::Uri doesn't allow urls with empty authority, hence parsing unix:///var/run/docker.sock will fail. * Remove empty /lib.rs * Fix cargo fmt
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2dad6ce..c87e926 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,31 +18,31 @@ coveralls = { repository = "softprops/shipflit" }
maintenance = { status = "actively-developed" }
[dependencies]
-base64 = "0.11"
+base64 = "0.13"
byteorder = "1.3"
-bytes = "0.4"
+bytes = "1.0"
chrono = { version = "0.4", optional = true, features = ["serde"] }
flate2 = "1.0"
futures-util = "0.3"
-futures_codec = "0.3"
-hyper = "0.13"
-hyper-openssl = { version = "0.8", optional = true }
-hyperlocal = { version = "0.7", optional = true }
+futures_codec = "0.4"
+hyper = { version = "0.14", features = ["client", "http1", "tcp", "stream"] }
+hyper-openssl = { version = "0.9", optional = true }
+hyperlocal = { version = "0.8", optional = true }
log = "0.4"
mime = "0.3"
openssl = { version = "0.10", optional = true }
-pin-project = "0.4"
+pin-project = "1.0"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
tar = "0.4"
-tokio = "0.2"
+tokio = "1.0"
url = "2.1"
[dev-dependencies]
-env_logger = "0.7"
+env_logger = "0.8"
# Required for examples to run
futures = "0.3.1"
-tokio = { version = "0.2.6", features = ["macros"] }
+tokio = { version = "1.0", features = ["macros", "rt-multi-thread"] }
[features]
default = ["chrono", "unix-socket", "tls"]