summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFelix Krull <f_krull@gmx.de>2018-09-08 01:39:08 +0200
committerFelix Krull <f_krull@gmx.de>2018-09-08 01:39:08 +0200
commit6e8a2179cfbfd447453475b9de4984a2c93ce377 (patch)
tree044e225c138192e21230059372b6f14e2f2ac576 /Cargo.toml
parent061853516312406019ae4344ba662480ba5a5988 (diff)
Make Unix socket support optional
By making Unix sockets optional, hyperlocal becomes optional as well, which means shiplift builds on Windows.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a67a892..fbde544 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ byteorder = "1.0.0"
flate2 = "0.2"
hyper = "0.10"
hyper-openssl = "0.2"
-hyperlocal = "0.3"
+hyperlocal = { version = "0.3", optional = true }
jed = "0.1"
log = "0.3"
openssl = "0.9"
@@ -27,3 +27,7 @@ serde_derive = "1.0"
[dev-dependencies]
env_logger = "0.4.0"
+
+[features]
+default = ["unix-socket"]
+unix-socket = ["hyperlocal"]