summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEli W. Hunter <42009212+elihunter173@users.noreply.github.com>2020-07-23 23:54:12 -0400
committerGitHub <noreply@github.com>2020-07-23 23:54:12 -0400
commit6cd1d7f93bd6f150341582a1b54087cefffdbf87 (patch)
tree88c109ec79e679d5aa041b20f074cf7b57d97cda /Cargo.toml
parenta4cd2185976ad56b880d5a10374c4dee6d116e6a (diff)
Async/Await Support (continuation of #191) (#229)
* it builds! * remove unused dependencies * bump dependencies * reimplement 'exec' endpoint * update a few more examples * update remaining examples * fix doc tests, remove unused 'read' module * remove feature-gated async closures * split futures dependency to just 'futures-util' * update version and readme * make functions accepting Body generic over Into<Body> again * update changelog * reinstate 'unix-socket' feature * reinstate 'attach' endpoint * fix clippy lints * fix documentation typo * fix container copyfrom/into implementations * add convenience methods for TtyChunk struct * remove 'main' from code example to silence clippy lint * Update hyper to 0.13.1 * Add Send bounds to TtyWriter * Appease clippy * Fix examples * Update issue in changelog Co-authored-by: Daniel Eades <danieleades@hotmail.com> Co-authored-by: Marc Schreiber <marc.schreiber@aixigo.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 12 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c85ed4e..2dad6ce 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,28 +18,31 @@ coveralls = { repository = "softprops/shipflit" }
maintenance = { status = "actively-developed" }
[dependencies]
-log = "0.4"
-mime = "0.3"
base64 = "0.11"
byteorder = "1.3"
bytes = "0.4"
chrono = { version = "0.4", optional = true, features = ["serde"] }
flate2 = "1.0"
-futures = "0.1"
-hyper = "0.12"
-hyper-openssl = { version = "0.7", optional = true }
-hyperlocal = { version = "0.6", optional = true }
+futures-util = "0.3"
+futures_codec = "0.3"
+hyper = "0.13"
+hyper-openssl = { version = "0.8", optional = true }
+hyperlocal = { version = "0.7", optional = true }
+log = "0.4"
+mime = "0.3"
openssl = { version = "0.10", optional = true }
+pin-project = "0.4"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
tar = "0.4"
-tokio = "0.1"
-tokio-codec = "0.1"
-tokio-io = "0.1"
+tokio = "0.2"
url = "2.1"
[dev-dependencies]
env_logger = "0.7"
+# Required for examples to run
+futures = "0.3.1"
+tokio = { version = "0.2.6", features = ["macros"] }
[features]
default = ["chrono", "unix-socket", "tls"]