summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAntoine Büsch <antoine.busch@gmail.com>2018-09-29 16:47:42 +1000
committerAntoine Büsch <antoine.busch@gmail.com>2018-09-29 16:47:42 +1000
commit36ef9c5800e2828c6be9d84b5922baf0f7bc5f95 (patch)
tree22d57bbb8518e2982c94dc4c28a759453b2c3d0f /Cargo.toml
parent3e2a40cbf272931f2374d8101dc59ab00bdf528a (diff)
parenteec5876731b40f0074a71793efa0b0f4f627989f (diff)
Merge branch 'master' into update-to-hyper-0.12
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9f0b352..b97d6ad 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,7 +16,7 @@ flate2 = "0.2"
http = "0.1"
hyper = "0.12"
hyper-openssl = "0.6"
-hyperlocal = "0.6"
+hyperlocal = { version = "0.6", optional = true }
jed = "0.1"
log = "0.3"
mime = "0.3"
@@ -30,3 +30,7 @@ serde_derive = "1.0"
[dev-dependencies]
env_logger = "0.4.0"
+
+[features]
+default = ["unix-socket"]
+unix-socket = ["hyperlocal"]