summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDylan McKay <me@dylanmckay.io>2018-08-06 19:17:22 +1200
committerDylan McKay <me@dylanmckay.io>2018-08-07 19:14:37 +1200
commit1b8e837ba25fd3eb4a042bb41083804de7c8c283 (patch)
treeb03cec3b9d27c57780e5a3f9aea24668d8c99931 /Cargo.toml
parent52ece44740f8ea80d11f269be99706d6e2a4bd13 (diff)
Update to Hyper 0.12
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a67a892..efb830a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,15 +13,18 @@ license = "MIT"
[dependencies]
byteorder = "1.0.0"
flate2 = "0.2"
-hyper = "0.10"
-hyper-openssl = "0.2"
-hyperlocal = "0.3"
+http = "0.1"
+hyper = "0.12"
+hyper-openssl = "0.6"
+hyperlocal = { git = "https://github.com/dylanmckay/hyperlocal.git", branch = "update-hyper" }
jed = "0.1"
log = "0.3"
-openssl = "0.9"
+mime = "0.3"
+openssl = "0.10"
rustc-serialize = "0.3"
tar = "0.4"
-url = "0.5"
+tokio-core = "0.1"
+url = "1.7"
serde = "1.0"
serde_derive = "1.0"