summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorrsdy <rsdy@users.noreply.github.com>2019-01-09 02:24:14 +0000
committerdoug tangren <d.tangren@gmail.com>2019-01-08 21:24:14 -0500
commit0ca553e5976acd49f2b9177755e1b2c685c19e48 (patch)
tree9561ee778b00c9869618fcd5c3793ac5fff69231 /Cargo.toml
parent4a6117df2eefd2a6878a44fbcdb97be6ac17355b (diff)
Make TLS/openssl an optional dependency (#130)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c6fd0ab..55a0a03 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,11 +24,11 @@ flate2 = "1"
futures = "0.1"
http = "0.1"
hyper = "0.12"
-hyper-openssl = "0.6"
+hyper-openssl = { version = "0.6", optional = true }
hyperlocal = { version = "0.6", optional = true }
log = "0.4"
mime = "0.3"
-openssl = "0.10"
+openssl = { version = "0.10", optional = true }
tar = "0.4"
tokio = "0.1"
tokio-codec = "0.1"
@@ -42,5 +42,6 @@ serde_json = "1"
env_logger = "0.5"
[features]
-default = ["unix-socket"]
+default = ["unix-socket", "tls"]
unix-socket = ["hyperlocal"]
+tls = ["openssl", "hyper-openssl"]