summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-01-10 13:06:37 +0100
committerMatthias Beyer <mail@beyermatthias.de>2020-01-10 13:06:37 +0100
commit5f6654ce1b93c60a30a8caa93b6daf07877915f7 (patch)
tree0a61bbcd673c832abde6261aeaaf80ee62991468 /Cargo.toml
Initial import of serde-select code
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..83d21cd
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "serde-select"
+version = "0.1.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+edition = "2018"
+description = "Query serde de/serializable objects"
+readme = "README.md"
+keywords = ["serde", "extension"]
+license = "MPL-2.0"
+repository = "https://github.com/matthiasbeyer/serde-select"
+
+[dependencies]
+failure = "0.1"
+failure_derive = "0.1"
+serde = "1"
+regex = "1.0"
+log = "0.4"
+lazy_static = "1.0"
+
+[dependencies.serde_json]
+versions = "1"
+optional = true
+
+[dependencies.toml]
+versions = "0.5"
+optional = true
+
+[features]
+default = ["backend_toml", "backend_serde_json"]
+
+backend_toml = ["toml"]
+backend_serde_json = ["serde_json"]
+