summaryrefslogtreecommitdiffstats
AgeCommit message (Expand)Author
2020-04-08openpgp: Unify ComponentAmalgamation and KeyAmalgamation.neal/unify-component-key-amalgamationNeal H. Walfield
2020-04-08openpgp: Allow ComponentAmalgamation specializations to add fieldsNeal H. Walfield
2020-04-08openpgp: Add some type aliases.Neal H. Walfield
2020-04-08openpgp: Implement From<&Cert> for RevocationKeyNeal H. Walfield
2020-04-07openpgp: Support setting designated revocations on new keysNeal H. Walfield
2020-04-07openpgp: Avoid unnecessarily duplicating the revocation keysNeal H. Walfield
2020-04-07openpgp: Implement VerifiedCert::revocation_keysNeal H. Walfield
2020-04-07openpgp: Allow setting multiple designated revokersNeal H. Walfield
2020-04-07openpgp: Simplify some default time unwrappingIgor Matuszewski
2020-04-07openpgp: Simplify Key4::has_unencrypted_secretIgor Matuszewski
2020-04-07openpgp: Simplify for loop in AES key unwrappingIgor Matuszewski
2020-04-07openpgp: Move key related functionality to KeyAmalgamation.Neal H. Walfield
2020-04-07openpgp: Improve documentation for the serialize module.Justus Winter
2020-04-07openpgp: Remove convenience methods that don't improve convenienceNeal H. Walfield
2020-04-07openpgp: Remove redundant implementations of direct_key_signatureNeal H. Walfield
2020-04-07openpgp: Add forwarders to ComponentAmalgamation.Neal H. Walfield
2020-04-06openpgp: Rename as_slice to as_bytes.Nora Widdecke
2020-04-06openpgp: Rename VerificationHelper::get_public_keys to get_certs.Justus Winter
2020-04-06openpgp: Make Signer::creation_time polymorphic.Justus Winter
2020-04-06openpgp: Introduce (mandatory, for now) crypto-nettle feature flagIgor Matuszewski
2020-04-03openpgp: Rename ComponentBundleIter to ComponentAmalgamationIter.Neal H. Walfield
2020-04-03openpgp: Rename cert/amalgamation/iter.rs to keyiter.rsNeal H. Walfield
2020-04-03openpgp: Return impl Iterator instead of a concrete typeNeal H. Walfield
2020-04-03openpgp: Implement From<Cert> for PacketPile.Neal H. Walfield
2020-04-03openpgp: Implement FromIterator<Packet> for PacketPile.Neal H. Walfield
2020-04-03Release 0.16.0.v0.16.0Justus Winter
2020-04-03Pin dependencies to keep our MSRV stable.Justus Winter
2020-04-03openpgp: Unawkwardify the streaming encryptor.Justus Winter
2020-04-03openpgp: Make LiteralWriter::date polymorphic.Justus Winter
2020-04-03openpgp: Rename.Justus Winter
2020-04-03Change function names to align to Rust naming conventions.Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `CTB::from_ptag` to `TryFrom<u8>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `Message::from_packets` to `TryFrom<Vec<Packet>>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `Message::from_packet_pile` to `TryFrom<PacketPile>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `Sexp::from_ciphertext` to `TryFrom<&mpis::Ciphertext>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `CertParser::from_packet_parser` to `From<PacketParserResult>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `PacketPile::from_packet_parser` to `TryFrom<PacketParserRes...Wiktor Kwapisiewicz
2020-04-03openpgp: Convert Cert::from_packet_parser into TryFrom<PacketParserResult>Wiktor Kwapisiewicz
2020-04-03openpgp: Unify Message and writer::Stack, hide writers.Justus Winter
2020-04-03openpgp: Rename.Justus Winter
2020-04-03openpgp: Keep the error from the most recent binding signature.Neal H. Walfield
2020-04-03openpgp: Remove unused type.Neal H. Walfield
2020-04-03openpgp: Rename Primary to PrimaryKey.Neal H. Walfield
2020-04-03openpgp: Move key_amalgamation.rs to amalgamation/key.rs.Neal H. Walfield
2020-04-03openpgp: Rename KeyIter to KeyAmalgamationIterNeal H. Walfield
2020-04-03openpgp: Rename ComponentIter to ComponentBundleIterNeal H. Walfield
2020-04-03openpgp: Define types before we use them.Neal H. Walfield
2020-04-03openpgp: Fix some documentation.Neal H. Walfield
2020-04-03ci: Fix running tests on clones.Justus Winter
2020-04-02openpgp: Remove ComponentBundleIter and related types.Neal H. Walfield