summaryrefslogtreecommitdiffstats
AgeCommit message (Expand)Author
2020-04-05WIP: Disable unsupported assuan/gnupg code on Windowsigor/workwork-assuan-ipcIgor Matuszewski
2020-04-05ipc: Panic on GnuPG context creation failureIgor Matuszewski
2020-04-03openpgp: Rename ComponentBundleIter to ComponentAmalgamationIter.Neal H. Walfield
2020-04-03openpgp: Rename cert/amalgamation/iter.rs to keyiter.rsNeal H. Walfield
2020-04-03openpgp: Return impl Iterator instead of a concrete typeNeal H. Walfield
2020-04-03openpgp: Implement From<Cert> for PacketPile.Neal H. Walfield
2020-04-03openpgp: Implement FromIterator<Packet> for PacketPile.Neal H. Walfield
2020-04-03Release 0.16.0.v0.16.0Justus Winter
2020-04-03Pin dependencies to keep our MSRV stable.Justus Winter
2020-04-03openpgp: Unawkwardify the streaming encryptor.Justus Winter
2020-04-03openpgp: Make LiteralWriter::date polymorphic.Justus Winter
2020-04-03openpgp: Rename.Justus Winter
2020-04-03Change function names to align to Rust naming conventions.Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `CTB::from_ptag` to `TryFrom<u8>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `Message::from_packets` to `TryFrom<Vec<Packet>>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `Message::from_packet_pile` to `TryFrom<PacketPile>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `Sexp::from_ciphertext` to `TryFrom<&mpis::Ciphertext>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `CertParser::from_packet_parser` to `From<PacketParserResult>`Wiktor Kwapisiewicz
2020-04-03openpgp: Convert `PacketPile::from_packet_parser` to `TryFrom<PacketParserRes...Wiktor Kwapisiewicz
2020-04-03openpgp: Convert Cert::from_packet_parser into TryFrom<PacketParserResult>Wiktor Kwapisiewicz
2020-04-03openpgp: Unify Message and writer::Stack, hide writers.Justus Winter
2020-04-03openpgp: Rename.Justus Winter
2020-04-03openpgp: Keep the error from the most recent binding signature.Neal H. Walfield
2020-04-03openpgp: Remove unused type.Neal H. Walfield
2020-04-03openpgp: Rename Primary to PrimaryKey.Neal H. Walfield
2020-04-03openpgp: Move key_amalgamation.rs to amalgamation/key.rs.Neal H. Walfield
2020-04-03openpgp: Rename KeyIter to KeyAmalgamationIterNeal H. Walfield
2020-04-03openpgp: Rename ComponentIter to ComponentBundleIterNeal H. Walfield
2020-04-03openpgp: Define types before we use them.Neal H. Walfield
2020-04-03openpgp: Fix some documentation.Neal H. Walfield
2020-04-03ci: Fix running tests on clones.Justus Winter
2020-04-02openpgp: Remove ComponentBundleIter and related types.Neal H. Walfield
2020-04-02openpgp: Change Cert::subkeys to return KeyAmalgamations.Neal H. Walfield
2020-04-02openpgp: Change Cert::unknowns to return amalgamations.Neal H. Walfield
2020-04-02openpgp: Remove ComponentIter::bundles.Neal H. Walfield
2020-04-02openpgp: Add limits to round_down and round_up.Nora Widdecke
2020-04-02openpgp: Actually drop KeyID::from_hex.Justus Winter
2020-04-02openpgp-ffi: Use UserIDAmalgamations, not UserIDBundles.Neal H. Walfield
2020-04-02openpgp-ffo: Fix typo.Neal H. Walfield
2020-04-02openpgp-ffi: A Rust bool is a C _Bool, not a C int.Neal H. Walfield
2020-04-02ffi-macros: Increase the length of acceptable C type names.Neal H. Walfield
2020-04-02ffi-macros: Handle some special cases in ident2c.Neal H. Walfield
2020-04-02openpgp: Rename cert::components to cert::bundle.Neal H. Walfield
2020-04-02openpgp: Move the writer module to serialize::stream.Justus Winter
2020-04-02openpgp: Move the padding module to serialize::stream.Justus Winter
2020-04-02openpgp: Implement Default for packet::Literal.Justus Winter
2020-04-02openpgp: Rename.Justus Winter
2020-04-02openpgp: Rename PublicKeyAlgorithm::can_encrypt to for_encryption.Justus Winter
2020-04-02openpgp: Drop Keygrip::from_hex in favor of FromStr.Justus Winter
2020-04-02openpgp: Drop Fingerprint::from_hex in favor of FromStr.Justus Winter