summaryrefslogtreecommitdiffstats
path: root/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'store/Cargo.toml')
-rw-r--r--store/Cargo.toml14
1 files changed, 10 insertions, 4 deletions
diff --git a/store/Cargo.toml b/store/Cargo.toml
index 73536f76..46beefa0 100644
--- a/store/Cargo.toml
+++ b/store/Cargo.toml
@@ -22,14 +22,20 @@ gitlab = { repository = "sequoia-pgp/sequoia" }
maintenance = { status = "actively-developed" }
[features]
-default = ["background-services"]
+default = ["background-services", "sequoia-openpgp/default"]
background-services = []
+crypto-nettle = ["sequoia-openpgp/crypto-nettle"]
+crypto-cng = ["sequoia-openpgp/crypto-cng"]
+compression = ["sequoia-openpgp/compression"]
+compression-deflate = ["sequoia-openpgp/compression-deflate"]
+compression-bzip2 = ["sequoia-openpgp/compression-bzip2"]
+
[dependencies]
-sequoia-openpgp = { path = "../openpgp", version = "0.19" }
+sequoia-openpgp = { path = "../openpgp", version = "0.19", default-features = false }
sequoia-core = { path = "../core", version = "0.19" }
-sequoia-ipc = { path = "../ipc", version = "0.19" }
-sequoia-net = { path = "../net", version = "0.19" }
+sequoia-ipc = { path = "../ipc", version = "0.19", default-features = false }
+sequoia-net = { path = "../net", version = "0.19", default-features = false }
anyhow = "1"
capnp = "0.10"
capnp-rpc = "0.10"