summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml52
1 files changed, 26 insertions, 26 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 55be6cd2..e2868213 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -25,41 +25,41 @@ gitlab = { repository = "sequoia-pgp/sequoia" }
maintenance = { status = "actively-developed" }
[dependencies]
-anyhow = "1.0.5"
+anyhow = "=1.0.5"
buffered-reader = { path = "../buffered-reader", version = "0.20", default-features = false }
-base64 = "0.13"
-bzip2 = { version = "0.4", optional = true }
-dyn-clone = "1"
-flate2 = { version = "1.0.1", optional = true }
-idna = "0.2"
-lalrpop-util = "0.19"
-lazy_static = "1.4.0"
-libc = "0.2.66"
-memsec = { version = "0.6", default-features = false }
-nettle = { version = "7", optional = true }
-regex = "1"
-sha1collisiondetection = { version = "0.2.2", default-features = false, features = ["std"] }
-thiserror = "1.0.2"
-backtrace = "0.3.46"
-unicode-normalization = "0.1.9"
+base64 = "=0.13.0"
+bzip2 = { version = "=0.4.1", optional = true }
+dyn-clone = "=1.0.0"
+flate2 = { version = "=1.0.1", optional = true }
+idna = "=0.2.0"
+lalrpop-util = "=0.19.0"
+lazy_static = "=1.4.0"
+libc = "=0.2.66"
+memsec = { version = "=0.6.0", default-features = false }
+nettle = { version = "=7.0.0", optional = true }
+regex = "=1.0.0"
+sha1collisiondetection = { version = "=0.2.2", default-features = false, features = ["std"] }
+thiserror = "=1.0.2"
+backtrace = "=0.3.46"
+unicode-normalization = "=0.1.9"
[target.'cfg(windows)'.dependencies]
-win-crypto-ng = { version = "0.4", features = ["rand", "block-cipher"], optional = true }
-num-bigint-dig = { version = "0.6", default-features = false, optional = true }
-ed25519-dalek = { version = "1", default-features = false, features = ["rand", "u64_backend"], optional = true }
-winapi = { version = "0.3.8", default-features = false, features = ["bcrypt"], optional = true }
-eax = "0.3"
+win-crypto-ng = { version = "=0.4.0", features = ["rand", "block-cipher"], optional = true }
+num-bigint-dig = { version = "=0.6.0", default-features = false, optional = true }
+ed25519-dalek = { version = "=1.0.0", default-features = false, features = ["rand", "u64_backend"], optional = true }
+winapi = { version = "=0.3.8", default-features = false, features = ["bcrypt"], optional = true }
+eax = "=0.3.0"
[target.'cfg(all(target_arch = "wasm32", target_os = "unknown"))'.dependencies]
-chrono = { version = "0.4.10", default-features = false, features = ["std"] }
+chrono = { version = "=0.4.10", default-features = false, features = ["std"] }
[build-dependencies]
-lalrpop = "0.19"
+lalrpop = "=0.19.0"
[dev-dependencies]
-quickcheck = { version = "0.9", default-features = false }
-rand = { version = "0.7", default-features = false }
-rpassword = "5.0"
+quickcheck = { version = "=0.9.0", default-features = false }
+rand = { version = "=0.7.0", default-features = false }
+rpassword = "=5.0.0"
[features]
default = ["compression", "crypto-nettle"]