summaryrefslogtreecommitdiffstats
path: root/ipc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipc/Cargo.toml')
-rw-r--r--ipc/Cargo.toml38
1 files changed, 19 insertions, 19 deletions
diff --git a/ipc/Cargo.toml b/ipc/Cargo.toml
index 6b443693..8f01e6f2 100644
--- a/ipc/Cargo.toml
+++ b/ipc/Cargo.toml
@@ -23,32 +23,32 @@ maintenance = { status = "actively-developed" }
sequoia-openpgp = { path = "../openpgp", version = "0.20", default-features = false }
sequoia-core = { path = "../core", version = "0.20" }
-anyhow = "1.0.5"
+anyhow = "=1.0.5"
buffered-reader = { path = "../buffered-reader", version = "0.20", default-features = false }
-capnp-rpc = "0.13"
-fs2 = "0.4.2"
-futures = "0.3.5"
-lalrpop-util = "0.19"
-lazy_static = "1.4.0"
-libc = "0.2.66"
-memsec = { version = "0.6", default-features = false }
-rand = { version = "0.7", default-features = false }
-tempfile = "3.1"
-thiserror = "1.0.2"
-tokio = { version = "0.2.19", features = ["rt-core", "rt-util", "tcp", "uds", "io-util", "macros"] }
-tokio-util = { version = "0.3", features = ["compat"] }
-socket2 = "0.3.16"
+capnp-rpc = "=0.13.0"
+fs2 = "=0.4.2"
+futures = "=0.3.5"
+lalrpop-util = "=0.19.0"
+lazy_static = "=1.4.0"
+libc = "=0.2.66"
+memsec = { version = "=0.6.0", default-features = false }
+rand = { version = "=0.7.0", default-features = false }
+tempfile = "=3.1.0"
+thiserror = "=1.0.2"
+tokio = { version = "=0.2.19", features = ["rt-core", "rt-util", "tcp", "uds", "io-util", "macros"] }
+tokio-util = { version = "=0.3.0", features = ["compat"] }
+socket2 = "=0.3.16"
[target.'cfg(windows)'.dependencies]
-winapi = { version = "0.3.8", default-features = false, features = ["winsock2"] }
-ctor = "0.1"
+winapi = { version = "=0.3.8", default-features = false, features = ["winsock2"] }
+ctor = "=0.1.0"
[build-dependencies]
-lalrpop = "0.19"
+lalrpop = "=0.19.0"
[dev-dependencies]
-clap = "2.33"
-quickcheck = { version = "0.9", default-features = false }
+clap = "=2.33.0"
+quickcheck = { version = "=0.9.0", default-features = false }
[features]
default = ["sequoia-openpgp/default"]