summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml13
1 files changed, 10 insertions, 3 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index 88ed983..1520c95 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -15,9 +15,15 @@ license = "MIT OR Apache-2.0"
travis-ci = { repository = "ferristseng/rust-ipfs-api" }
[features]
-default = ["hyper", "hyper-multipart-rfc7578", "hyper-tls", "failure"]
-actix = ["actix-http", "actix-multipart-rfc7578", "awc", "derive_more"]
-builder = ["typed-builder"]
+default = ["with-hyper-tls", "with-builder"]
+with-hyper-tls = ["with-hyper", "hyper-tls"]
+with-hyper-rustls = ["with-hyper", "hyper-rustls"]
+with-hyper = ["hyper", "hyper-multipart-rfc7578", "failure"]
+with-actix = ["actix-http", "actix-multipart-rfc7578", "awc", "derive_more"]
+with-builder = ["typed-builder"]
+# Old features, kept for compatibility
+actix = ["with-actix"]
+builder = ["with-builder"]
[dependencies]
actix-http = { version = "1.0", optional = true }
@@ -30,6 +36,7 @@ futures = "0.3"
http = "0.2"
hyper = { version = "0.13", optional = true }
hyper-tls = { version = "0.4", optional = true }
+hyper-rustls = { version = "0.20", optional = true }
hyper-multipart-rfc7578 = { version = "0.4.0-rc", optional = true }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"